"Legato" behavior

Moderator: Solaris Moderators

John Bowen
Site Admin
Posts: 1802
Joined: Sat Apr 07, 2007 3:00 am

Re: "Legato" behavior

Post by John Bowen » Tue Dec 03, 2013 5:59 pm

Hmmm, I did see it happen now....rebooting fixed the behavior. I'm not sure what I did to make it happen, though. That's the key, before we can fix the bug.

Patate le mgae
Posts: 136
Joined: Thu Nov 17, 2011 3:17 am

Re: "Legato" behavior

Post by Patate le mgae » Thu Dec 05, 2013 3:50 am

OK John i have found a way to reproduce the bug.
It makes no sense for me but it always function ( i tried 10 times and i obtain it 10 times )

Restart your unit
Begin with the usual init patch :
Choose :
Play mode : mono
Legato : Reassign
EgReset : Running
On the EG 6
Decay : 600 ms
Sustain : 20

all is fine

now store this patch and give it a new name ( this is important )


Now if you restart your unit and listen to the store patch you have made it's just fine.
If you store it again without changing is name all is fine.
If you store it and changing is name : Bug.

Now try this : restart your unit, listen the store patch : fine.
Make another patch, not in mono, not in reassign, not in running, store it on another location and change is name.
Go back to your mono patch : Bug.

So it seems that the saving procedure has something to do with this bug.
I don't know if it is the only way we can have the bug, but if it is the case, only the users who are storing sounds can have notice it.

John Bowen
Site Admin
Posts: 1802
Joined: Sat Apr 07, 2007 3:00 am

Re: "Legato" behavior

Post by John Bowen » Thu Dec 05, 2013 7:32 am

Excellent work! I'll check it later today as well.
Thanks for your help!


Posts: 26
Joined: Fri Feb 10, 2012 4:22 am
Location: Germany

Re: "Legato" behavior

Post by Christopher » Sat Dec 07, 2013 5:04 am

Great to see some progress on this issue.
Thank you Patate for figuring this out! I've tried it and I can definitely confirm that renaming Patches triggers this bug.

However I do remember running into this particular issue just by playing various patches without editing anything at all. So I had another go at hunting for this nasty bug and I believe I have found another way of triggering it. It seems to depend on what method I use to change patches. As long as I use just the numeric keypad or the up/down arrows to enter the bank and program numbers, everything is fine. But being an old Wavestation veteran, I like using the list view (page 3/3 of the "Preset" menu). If I switch patches by scrolling through the list using the alpha dial and then select the highlighted patch by pressing ENTER, this triggers the bug! In fact, it seems like selecting a new patch isn't even necessary. Just using the alpha dial in patch list mode instantly messes up the Legato behaviour.

Try this directly after booting the SOLARIS:
1) Select a monophonic patch which has the Legato parameter set to "Reassign" by using the keypad or the up/down arrows.
2) Play a few notes to confirm that "Reassign" works properly.
2) Go to patch list mode (page 3/3 of the "Preset" menu).
3) Use the alpha dial to scroll through the list.
4) Play a few notes; the patch now behaves as if the Legato parameter was set to "Retrigger".

John Bowen
Site Admin
Posts: 1802
Joined: Sat Apr 07, 2007 3:00 am

Re: "Legato" behavior

Post by John Bowen » Wed Feb 22, 2017 11:23 pm

OK, we have finally determined this Legato bug is due to a corrupted global INIT file!

The file is located in your Factory folder on your CF card, and is named, 'glo.ini'. Every time you boot the Solaris, this file is loaded, and it turns out there was some funky stuff going on when saving to the card and using the data wheel.

Anyway - please download this file from here, and I'll also put it in the Data Files section.
(174 Bytes) Downloaded 150 times

Post Reply