Solaris receives midi in and goes crazy

Moderator: Solaris Moderators

chapolin
Posts: 61
Joined: Thu Feb 26, 2015 4:35 pm
Location: France
Contact:

Re: Solaris receives midi in and goes crazy

Post by chapolin » Thu May 28, 2015 3:41 am

Just for info I have an opposite problem.

I use midi sequences from my daw (ardour4) to the solaris midi connected (with a multiface II) and it work fine.

ardour out ---> solaris in = work fine

But when the solaris is connected midi out to the multiface midi in, I have problems and it disrupt latency, my system become unstable, so I have audio cliks (and xruns who are disturbances notifications in linux) when I record a midi sequence from playing on the solaris keyboard. The problem disappears with "MIDIctrl off".

I use a linux system with a kernel realtime. The settings to record are 96 KHz with a latency of 2.67 ms. For doing that the kernel rt allow to give a high level priority to the multiface irq but not to set the priority of midi or audio separately in the multiface or after in the system. So I think that something in the midi signal from the solaris give the problem. If I record the midi from another keyboard, it work fine and xruns appear only if I use, for exemple, a lot of greedy plugins resources of mastering in ardour.

chapolin
Posts: 61
Joined: Thu Feb 26, 2015 4:35 pm
Location: France
Contact:

Re: Solaris receives midi in and goes crazy

Post by chapolin » Sat May 30, 2015 11:01 am

I need to adjust my last post, because i made a mistake, I tested to plug the solaris on my sound card (multiface II) but not my others synthesizers. Indeed they are plugged on a midi interface plugged on the computer with a usb connection. So it can not disrupt my computer system. So I tried to plug an other keyboard in the multiface with midi connection and the same problem appear.

If I connect the solaris on the midi usb interface all work fine :

solaris out ---> in M4UXT ---> ardour4 = work fine
ardour4 ---> M4UXT out ---> solaris in = work fine

If I plug the solaris with the usb connection, all work fine also with ardour4.
Last edited by chapolin on Tue Mar 15, 2016 1:40 am, edited 1 time in total.

chapolin
Posts: 61
Joined: Thu Feb 26, 2015 4:35 pm
Location: France
Contact:

Re: Solaris receives midi in and goes crazy

Post by chapolin » Mon Mar 14, 2016 6:48 am

On certain sounds I have some problem with the daw midi connected when I record and play: suddenly when I play on the solaris keyboard or with the daw, i have too time the sound. It solve the problem if I push the button "Arp on" two times or if I set "Legato" off in "Home" 1/4 as it is is mentioned above in this thread.
Last edited by chapolin on Mon Mar 14, 2016 3:15 pm, edited 1 time in total.

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Mon Mar 14, 2016 10:27 am

chapolin wrote:On certain sounds I have some problem with the daw midi connected when I record and play: suddenly when I play on the solaris keyboard or withe the daw, i have too time the sound. It stop if I push the button "Arp on" two times or if I set "Legato" off in "Home" 1/4 as it is is mentioned above in this thread.
Anyone having some strange MIDI problems, please contact me to get v1.2.1 OS.

info@johnbowen.com

Post Reply