Solaris receives midi in and goes crazy

Moderator: Solaris Moderators

Patate le mgae
Posts: 136
Joined: Thu Nov 17, 2011 3:17 am

Re: Solaris receives midi in and goes crazy

Post by Patate le mgae » Wed Jun 26, 2013 2:18 am

I try something else, it can help to locate the problem :
Kronos : Midi out ( no audio )
Solaris : Midi in ( Sort of dark piano )
Solaris : Midi thru
Doepfer : Midi in ( White noise )
I play staccato on the Kronos Keyboard.
Some notes are missing on the solaris, but are there from the modular system.
So it's not the transmission wich cause the problem but the way the solaris work with midi flow.
Here is the sample :
https://soundcloud.com/patate-le-mage/b ... thrumodula

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Fri Jun 28, 2013 2:57 am

Ok folks. I think i found the cause for my problem (and the solution).
So far its working. I'll need to try and see wether this works with usb as well.
It seems that there ARE special settings in cubase for when you use the same synth both as a controller and as a soundsource at the same time. There's a "midi thru active" which you need to disable in order to avoid a midi feedback loop.
I just found out, and i'm hoping this will hold on. I'll let Solaris run for a couple of hours and see how it goes. :)

However, it seems the Solaris doesn't sync very well. I've set it to receive ext clock. Cubase running on 127 bpm. I can see Solaris locking on 127, but toggles back and forth from 127 to 126. The result is when i try to record an arp -it goes in and out of sync. :?

Edit:
Perhaps celebrations were a bit too early...
The Solaris didn't go crazy. But as soon as i wanted it to control other synths - it couldn't. So as long as the "midi thru active" is disabled - i can record midi and sequence the Solaris, while Solaris is the master keyboard, with no glitches - but lose control over other synths. Or i enble the "midi thru active" and control other synths with no problems - but when trying to sequence Solaris it goes crazy.
It seems like it's a thing that can work - as long as i change the settings each time before i record, accordingly.
I have yet found a solution that works all the time.
Last edited by Zahush76 on Fri Jun 28, 2013 3:46 am, edited 1 time in total.

wouter
Posts: 47
Joined: Sat Sep 15, 2012 11:06 am

Re: Solaris receives midi in and goes crazy

Post by wouter » Fri Jun 28, 2013 3:46 am

So this could be a configuration problem instead of a bug. Also look at the localoff feature in the Solaris manual.
Electronic Music - www.insanic4.com | Music Production Resources - www.granucon.com | Netlabel - www.sonicengram.com | Multitouch Controller - www.gesturespark.com

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Fri Jun 28, 2013 3:47 am

wouter wrote:So this could be a configuration problem instead of a bug. Also look at the localoff feature in the Solaris manual.
Local off is off. It comes this way as a factory default.
Also look at the edit i've made to my post. Didn't work 100% - but certainly an improvement.

wouter
Posts: 47
Joined: Sat Sep 15, 2012 11:06 am

Re: Solaris receives midi in and goes crazy

Post by wouter » Fri Jun 28, 2013 6:42 am

Zahush76 wrote:
wouter wrote:So this could be a configuration problem instead of a bug. Also look at the localoff feature in the Solaris manual.
Local off is off. It comes this way as a factory default.
Also look at the edit i've made to my post. Didn't work 100% - but certainly an improvement.
But LocalOff should be on if you have MIDI thru enabled in your sequencer.
Electronic Music - www.insanic4.com | Music Production Resources - www.granucon.com | Netlabel - www.sonicengram.com | Multitouch Controller - www.gesturespark.com

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Fri Jun 28, 2013 10:40 am

wouter wrote:
Zahush76 wrote:
wouter wrote:So this could be a configuration problem instead of a bug. Also look at the localoff feature in the Solaris manual.
Local off is off. It comes this way as a factory default.
Also look at the edit i've made to my post. Didn't work 100% - but certainly an improvement.
But LocalOff should be on if you have MIDI thru enabled in your sequencer.
Sorry, but it's the complete opposite. I enabled the midi thru, and set localOff to on - it it went crazy.
Tried this twice, and each time i did as you said- i ended up with a constant stuck note,and had no option but reboot again and again.

marzzz
Posts: 221
Joined: Mon Dec 01, 2008 8:07 pm

Re: Solaris receives midi in and goes crazy

Post by marzzz » Fri Jun 28, 2013 4:17 pm

Zahush76 wrote:Local off is off. It comes this way as a factory default.
That reminds me- can we rename this parameter something like "Local Ctrl" so that it makes more sense? Local Off is Off is quite confusing... :?:

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Fri Jun 28, 2013 6:30 pm

Yes, this has always been an area for confusion. I think we should probably not have used 'Off' in the parameter name, just 'Local'. Read this from an online description:

"LOCAL ON/OFF : MIDI Channel Message that sets whether your keyboard is going to trigger its internal sounds (Local ON) or not (Local OFF). This is a vital parameter to have control over in order to avoid loops and double-triggers when your keyboard is part of a larger, computer-involving rig of equipment "

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Fri Jun 28, 2013 9:28 pm

John Bowen wrote:Yes, this has always been an area for confusion. I think we should probably not have used 'Off' in the parameter name, just 'Local'. Read this from an online description:

"LOCAL ON/OFF : MIDI Channel Message that sets whether your keyboard is going to trigger its internal sounds (Local ON) or not (Local OFF). This is a vital parameter to have control over in order to avoid loops and double-triggers when your keyboard is part of a larger, computer-involving rig of equipment "
Wel, now when i activate LocalOff - the Solaris only receives midi from cubase and acts as a sound module - but doesn't send any midi out. I.e, when i try controlling other synths or plugins with it than nothing happens. And naturally, i can't play the Solaris it self since it cuts off the conection between the solaris keboard and its sound engine.
Someone has the address of mr Dave smith? The man responsible for all this confusion :wink:

I just had to... :
http://www.youtube.com/watch?v=ZHYyazhBXcw

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Sat Jun 29, 2013 5:50 am

John Bowen wrote:Yes, this has always been an area for confusion. I think we should probably not have used 'Off' in the parameter name, just 'Local'. Read this from an online description:

"LOCAL ON/OFF : MIDI Channel Message that sets whether your keyboard is going to trigger its internal sounds (Local ON) or not (Local OFF). This is a vital parameter to have control over in order to avoid loops and double-triggers when your keyboard is part of a larger, computer-involving rig of equipment "
Are you sure about this? It seems like in Solaris it's the other way around. First of all, just as a varification - i checked the solaris by itself, when not connected to anythin midi-wise.
If i set "LocalOff" to "on" - i play the keyboard and it doesn't trigger any sound.
On the other hand, if i set LocalOff to "off" - than the keyboard triggers the internal sounds, and it acts as a "normal" synth.
This is exactly the opposite of the definition you quoted.

Anyway, i've been to several forums, asking wether my connectiions, settings and prefferencess in Cubase are correct - and it seems they indeed are. It's supposed to be quite simple:
The way it should work is - set cubase "midi thru active", to "active".
The Solaris should be set to Local Off (the name you chose is so confusing - but what i'm looking for is to detach the keyboard from the sound engine).
That's supposed to be it.
Other than that - the Solaris is connected via midi propperly to my interface. Cubase recognizes the interface by name, and shows that midi in and midi out are active.

If Solaris "LocalOff" is set to "on" - than it only receives midi. It doesn't send anything. It's just a sound engine. When i play the keys - the midi meter on the cubase transport shows nothing, which means no incoming midi.
(btw - the cables are fine. i've used them with my other synths up till now).

When i set "LocalOff" to "off" than first - the transport shows on the meter that there's incoming midi when i press the keys.
And like i wrote before - when "midi thru active" is active, both cubase and Solaris go "crazy" when i try to record midi to the midi channel routed to Solaris. However, in this situation i can use Solaris to play\trigger other synths\plugins.
When "midi thru active" is deactivated, than i can record and playback midi out from Solaris and back to itself. But then it doesn't control other synths\plugins anymore.

It seems there is some kind of problem - on my unit anyway - for the Solaris to succesfully seperate the keyboard from the sound engine.
I'll know better later this week. A friend of mine is supposed to come with his Nord Stage just so that we could check and be sure if this phenomena is happening to all the synths i connect to my DAW - or just the Solaris.

I don't have a lot of hair left... :mrgreen:

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Sat Jun 29, 2013 8:00 am

Zahush76 wrote:
John Bowen wrote:Yes, this has always been an area for confusion. I think we should probably not have used 'Off' in the parameter name, just 'Local'. Read this from an online description:

"LOCAL ON/OFF : MIDI Channel Message that sets whether your keyboard is going to trigger its internal sounds (Local ON) or not (Local OFF). This is a vital parameter to have control over in order to avoid loops and double-triggers when your keyboard is part of a larger, computer-involving rig of equipment "
Are you sure about this? It seems like in Solaris it's the other way around. First of all, just as a verification - i checked the solaris by itself, when not connected to anything midi-wise.
If i set "LocalOff" to "on" - i play the keyboard and it doesn't trigger any sound.
On the other hand, if i set LocalOff to "off" - than the keyboard triggers the internal sounds, and it acts as a "normal" synth.
This is exactly the opposite of the definition you quoted.
Funny that 2 people can read the same thing, yet get the opposite understanding!

It is exactly correct, that with when Local is set to Off, as in the explanation I quoted, the keyboard is disconnected from the internal sound engine (the 'local' sound engine), and only then will play the local sound engine from incoming MIDI. It also is correct that, with Local set to Off, the keyboard still sends out MIDI to control other things. This is stated in that definition.

However, I think the confusion is in the labeling of the parameter = when we say LocalOff is On, that is the same thing as Local is set to Off...so, I think it's the fault that we labeled it poorly (when LocalOff is ON, it means there's no connection between the Solaris keyboard and its internal sound engine).

I'll have him change the label in the next OS.

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Sat Jun 29, 2013 8:11 am

Zahush76 wrote:When i set "LocalOff" to "off" than first - the transport shows on the meter that there's incoming midi when i press the keys.
And like i wrote before - when "midi thru active" is active, both cubase and Solaris go "crazy" when i try to record midi to the midi channel routed to Solaris. However, in this situation i can use Solaris to play\trigger other synths\plugins.
When "midi thru active" is deactivated, than i can record and playback midi out from Solaris and back to itself. But then it doesn't control other synths\plugins anymore.
This is a good description, and it's very clear to me where the problem is. Let me see if I can clarify for you:

What is happening when you turn on the "midi thru active" is that the incoming MIDI signal is immediately being routed back to the outputs at the same time. This will cause a MIDI loop to the Solaris, as you have noted, but it also is sending the MIDI from the Solaris directly to the other synths, which is what you want.

If the Solaris keyboard is disconnected (LocalOff = On), it is supposed to send out MIDI notes, that then go through cubase's "MIDI thru", and back to the Solaris sound engine. As you posted, this should be all you have to do.

So, the odd thing is that you are saying there is no MIDI output from the keyboard in this situation. There should be, and when I test it here with my system, it does work correctly.

What happens when you connect the Solaris output to another synth? The Solaris should be playing the other synth in both LocalOff settings.

john b.

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Sat Jun 29, 2013 8:34 am

Also, SendArp must be set to Off. This only works when the Arpeggiator is running, which needs the local keyboard connected to the sound engine. Perhaps this is the one thing that you need to change?

Zahush76
Posts: 108
Joined: Tue Aug 07, 2012 12:33 am

Re: Solaris receives midi in and goes crazy

Post by Zahush76 » Sat Jun 29, 2013 9:10 am

John Bowen wrote:Also, SendArp must be set to Off. This only works when the Arpeggiator is running, which needs the local keyboard connected to the sound engine. Perhaps this is the one thing that you need to change?
Huh! Mazal Tov! That did the trick. LocalOff when turned "on" doesn't send anything when SendArp is on. I set the SendArp to off - and now it's fine. Thanks!
Next will be to see how it handles the usb.

edit: usb still doesn't respond. cubase recognizes the solaris by name, but nothing - while in the same settings, when i switch to midi cables it works... :roll:

John Bowen
Site Admin
Posts: 1749
Joined: Sat Apr 07, 2007 3:00 am

Re: Solaris receives midi in and goes crazy

Post by John Bowen » Sat Jun 29, 2013 9:20 am

I wonder if Cubase treats USB MIDI differently than via the MIDI interface you have?

Post Reply