Page 1 of 1

Arp not clocking/triggering correct.

Posted: Sun Jun 11, 2017 1:09 am
by M-Prod
When played from my cirklon (with rock solid timing and midi). Often some arp notes do not trigger correctly. (i know because when i turn off the arp, the notes are dead timed solid). It seems to be most obvious om CK patterns and less noticeable in P3 patterns.
Either the arp starts late, or notes are triggered off the grid. Especially when triggering chords you can hear that all the notes briefly play when the chord strikes, like a 'very quick arpeggio' before the actual arp starts. The first time i start the sequence it sounds ok-ish, but as soon as i add and remove notes in the cirklon, the more clearly you can hear the chord triggered as a whole (instead of one by one, as it should, because it's an arp) and that causes the arp to delay as a whole.

After extensive testing my guess is this is related to sending both the clock (reset) and notes at the same time. Because when i stop sending clock, the notes play correct (although out of sync after a while as a whole when the bpm does not match).
I hope i make myself clear.

Re: Arp not clocking/triggering correct.

Posted: Mon Jun 12, 2017 8:49 am
by minorguy
I don't understand your explanation and I'm not sure what you're trying to accomplish. The cirklon is sending out notes of its sequence to the Solaris, but then you also have the Solaris arp turned on, is that right? When the Solaris arp is on, notes received are not really notes but are controls that tell the arp what notes are to be in the arpeggio. I can understand it if you're using the CK type pattern and recording notes played on the Solaris keyboard (as if recording to a DAW). But P3 patterns are sequences in their own right, true? Not typically something to control another arpeggiator. So I guess I'm confused.
Also, what is your OS version and relevant settings on the Solaris? Do you have MIDI clock set to Ext/Auto? Is Realtime enabled? Does the cirklon send a MIDI Start message?

Re: Arp not clocking/triggering correct.

Posted: Tue Jun 13, 2017 11:55 am
by M-Prod
Thanks for you reply minor guy. And let me take the opportunity to thank you for your great work!
My OS is 1.3.1. The cirklon sends notes, tempo and reset (and tried different sync settings on the cirklon and all with the same result except whey i set mclk send to off) . The arp on the Solaris is on and clock is set to external (or auto, same results). I tried both with and without realtime enabled and the result is the same. I tried with P3 patterns mainly for testing if that made a difference. So never mind what i'm trying to achieve with that. Of course CK patterns are more relevant when working with the arp.
I attached a simple test file. The cirklon plays a simple chord in a CK pattern. ClkSrc is set to auto. The first part is with cirklon clock send enabled, the second without. In the first part you can hear the 'hiccup' I would expect the scenario where the arp tempo is also clocked by the cirklon to sound the same as the second part, in which the arp sounds correct ... t.mp3?dl=0

(i cannot attach audio files it seems disabled)

Maybe you can hear what's happening there.

Oh i tested a similar scenario with ableton (a chord send to the Solaris and clock sync out enabled in Ableton) and the results are the same so that might enable you to reproduce it (or you might have a cirklon too). Only with ableton it's less of a problem, because it only occurs the moment you start ableton. When the clip loops, the hiccup is gone. Unlike the cirklon where the hiccup returns every restart of the pattern.

Re: Arp not clocking/triggering correct.

Posted: Tue Jun 13, 2017 3:47 pm
by minorguy
I think I understand now and I might know what's going on. The Solaris arpeggiator always plays the first note immediately upon the first keypress instead of waiting for the next clock. The reason for doing that is because the timing feels more natural to the user pressing the keys. So if the chord is pressed (or sent over MIDI) just before a clock, the first note plays immediately and the second note plays at the first clock after that which might be very soon after.

It sounds like the first two notes of your arpeggio are being played very close together. So I think the chord that's being output is right before the first clock. Perhaps you can check this if you can look in the event list. And I would guess that the chord is being released and replayed every loop so the hiccup happens every loop.

To fix it, if possible have the chord played just after a clock instead of just before it. Or else, better yet, have the chord played well before any clocks are sent at all (and only played once).

Re: Arp not clocking/triggering correct.

Posted: Wed Jun 14, 2017 12:28 pm
by M-Prod
I also thought that might work. But I already tried to move the notes a little forward or backward but the hiccup remains. In the example I sent, the chord is triggered both at the start of the loop but also halfway and the hiccup also occurs there. Btw, all notes in the chord are triggered exactly at the same time.
I would guess its a cirklon thing but since ableton has the same issue (although not the second and further time around a loop, only when you press start actually), im confused where to look. What does ableton do when you press start that the cirklon does every time the chord is triggered while sending clock?? The only thing that helps is to turn off sync. That's my workaround right now.

Re: Arp not clocking/triggering correct.

Posted: Wed Jun 14, 2017 8:34 pm
by minorguy
Looking at this a little closer it looks like a bug. :( So far don't think there's a workaround for it. It will have to be fixed in later version.

Re: Arp not clocking/triggering correct.

Posted: Fri Sep 01, 2017 11:17 pm
by John Bowen
I’ve sent M-Prod a new beta OS that should fix this issue - waiting to hear back from him.