USB recognition since OS 1.4

Moderator: Solaris Moderators

Post Reply
akoasma
Posts: 7
Joined: Thu Jan 28, 2016 12:44 am

USB recognition since OS 1.4

Post by akoasma » Mon Dec 18, 2017 4:23 am

Hi... since the last OS-Update (1.4) Solaris is not recognized anymore... back to 1.3 solved the issue
Win7 64bit

John Bowen
Site Admin
Posts: 1718
Joined: Sat Apr 07, 2007 3:00 am

Re: USB recognition since OS 1.4

Post by John Bowen » Mon Dec 18, 2017 10:55 am

I’ve tested with Win10 and Mac Sierra, and the Solaris is being recognized right away over USB in both cases (using 1.4).
Jim is aware of your report, and so any other details you can provide would be helpful.

Benoist Guitton
Posts: 13
Joined: Mon Nov 27, 2017 3:16 pm

Re: USB recognition since OS 1.4

Post by Benoist Guitton » Sat Dec 30, 2017 10:30 am

Solaris not recognised as well here since 1.40.1 in ( updated ) Windows 10 Pro 64 bit

I've tried various USB ports, most times nothing happens at all and at best it's recognised ( kind of : there's a line of ... in the retrieve USB peripherals menu ) in parameters it's recognised but with a driver error message right of a loudspeaker icon ( I don't remember if it was recognised before as an USB or audio device )

John Bowen
Site Admin
Posts: 1718
Joined: Sat Apr 07, 2007 3:00 am

Re: USB recognition since OS 1.4

Post by John Bowen » Sat Dec 30, 2017 10:40 am

I tried it using Windows 10 Home 64 bit with no problem. Will ask Jim to check what else it could be.

Benoist Guitton
Posts: 13
Joined: Mon Nov 27, 2017 3:16 pm

Re: USB recognition since OS 1.4

Post by Benoist Guitton » Sat Dec 30, 2017 11:21 am

I took some screenshots for further investigations :

Image

Translation from left panel : this device can't start ( code 10 )

Image

Image

It seems Solaris have been installed from the lower informations panel ( yesterday I didnt check further ) but ...

pinmusica
Posts: 7
Joined: Tue Sep 13, 2016 2:01 am

Re: USB recognition since OS 1.4

Post by pinmusica » Thu Feb 15, 2018 12:05 pm

For me, also not recognized on Windows 7 64bit (OS 1.4)

Cheers

minorguy
Posts: 70
Joined: Fri Dec 05, 2014 12:09 pm
Location: San Jose, CA, USA

Re: USB recognition since OS 1.4

Post by minorguy » Fri Feb 16, 2018 8:03 am

Hi pinmusica,

In the Solaris, go to the MIDI page and make sure that MIDICtrl is On.

With the Solaris USB cable plugged in, do you see John Bowen Solaris Synthesizer in Device Manager? It should be in the section called Sound, video, and game controllers. If it is there, does it have an error?

What software are you using to test whether the Solaris is working? For people having trouble on Windows, please try using the free program MIDI-OX. Select Solaris as the MIDI device. Once you have it running, play some keys on the Solaris. Do you see notes appear on the Input Monitor window?

Do you also have a regular MIDI interface (5 pin). If so, can you confirm that the regular MIDI interface is working?
Solaris #249

pinmusica
Posts: 7
Joined: Tue Sep 13, 2016 2:01 am

Re: USB recognition since OS 1.4

Post by pinmusica » Thu Mar 22, 2018 7:05 am

Hi, minorguy

Please, accept my apologies for not answering earlier, as I have just got into the fórum and read your answer.
Thanks for all the indications, I'll check it tonight (once I get back from work), and I'll let you know. I use Reaper.

Sorry, again, as I only thought of this subject as a pasive place to indicate bugs, thus I did not expected the answer (I've been using MIDI since that).

I'd like to take the chance to thank you for all your great work you've been doing with John for the Solaris OS,

Thanks a lot for everything :)

pinmusica
Posts: 7
Joined: Tue Sep 13, 2016 2:01 am

Re: USB recognition since OS 1.4

Post by pinmusica » Thu Mar 22, 2018 1:13 pm

Hi, minorguy

Checked with MIDICtrl On and recognized by the device manager with no issues indicated, no signals received on MIDI-OX (it does receive from my other keyboards/synths) + working on Reaper with the same result.

It works fine with my MIDI interface (Microlite Motu) though.

Thanks again for the feedback + all you've done + once again, please accept my apologies.
(next thing tomorrow; I'll try with the new 1.4.1. I've run out of time today...)

Cheers

pinmusica
Posts: 7
Joined: Tue Sep 13, 2016 2:01 am

Re: USB recognition since OS 1.4

Post by pinmusica » Sat Apr 07, 2018 3:28 am

Hi again,

Got it working with the new system :)

Thanks, again, for everything

Cheers

Post Reply