MidiCtrl defaults to off in 1.4.2. Should be on

Moderator: Solaris Moderators

Post Reply
inaheartbeat
Posts: 34
Joined: Sat May 19, 2012 12:39 pm

MidiCtrl defaults to off in 1.4.2. Should be on

Post by inaheartbeat » Mon Feb 19, 2018 6:23 pm

John,

I upgraded my Solaris from 1.3 to 1.4.2 (which is overall great by the way....) and discovered it stopped working as a controller keyboard for my Parva. I used Midi-Ox to verify that no midi was being sent. It turned out that the MidiCtrl parameter was off when it should have been on. I have a few observations:

I think that the default got broken in 1.4.2.

I think that it is a confusing name at the very least for something that would affect note on/off and mod wheel messages coming out of the Solaris.

Maybe you need a separate parameter which directs the midi note stream out either no interface, USB, midi, or both USB and midi.

Thoughts?

Ken

John Bowen
Site Admin
Posts: 1736
Joined: Sat Apr 07, 2007 3:00 am

Re: MidiCtrl defaults to off in 1.4.2. Should be on

Post by John Bowen » Mon Feb 19, 2018 6:58 pm

This controls both MIDI in and out, and the default setting is saved with your Global INIT file (the Save option in your System page). V1.4.0.2 uses an expanded Global INIT file, so you do need to re-save your default settings.

I know some of the DSI stuff has the option to send MIDI via USB, DIN, or Both. I can discuss with Jim.

Post Reply